Re: Bug#10918: xringd: after the first ring my RD SD led are on (fwd)

Andrea Arcangeli (
Thu, 10 Jul 1997 12:14:51 +0200 (CEST)

I BOOTUP my machine, I run ./try (the program below) and I wait a ring.
After the ring (before getchar() is exited) the lines of the modem are
full of data and the respective leds are ON (it seems a loop inside the
modem Cardinal 28.800 v34/vFC). When I press RETURN and ./try close the
modem all return normal. If I relaunch ./try I get the same as above.

If I run pppd on the modem line before running ./try, when I receive the
ring, all remain normal and the modem led are off as usual.

It seems to be a kernel [2.x.x] problem because the only thing that cause
that is the open system call.

#include <stdio.h>
#include <fcntl.h>

void main(void) {
int fd;
printf("I am attempting to open modem device /dev/modem\n");
if((fd = open("/dev/modem",O_RDONLY))<0) {
printf("Modem not opened\n");
printf("Modem opened successfully\n");

Anybody can duplicate this problem on his hardware?

Thanks in advance!

Andrea Arcangeli