Quota grace period severely broken under Linux?

Zeev Suraski (bourbon@netvision.net.il)
Fri, 11 Jul 1997 22:17:18 +0300 (IDT)

This is exactly the same letter I've sent two days ago, only now I'm
beginning to assume the quota layer is really broken :( If I wasn't doing
anything wrong, then quota is seriously broken under Linux (the grace
period is anyway). I've tried mailing the quota author but got no
response yet either, which is the reason I'm reposting it. If anybody can
point me at a solution (or acknowledge that indeed quota is broken under
Linux 2.0.30) - I'd be grateful.

The orignal letter:


Recently (a couple of weeks ago), we've turned on quotas on one of our
Linux servers. When turning them on, something weird (== unexpected as
far as I was concerned) happened. Some of the users who were above their
quota (but below their limit) were given the grace period of 21 days, as
we wanted. However, some of them were simply given 'none' as a grace
I really cannot seem to find any link between all of those who got a grace
period and those who didn't. They're both between their quota and their
I've tried to play with it for some time - I tried increasing the
grace period to 100 days, it didn't help:

11:30 bourbon-ttyp2 nvlinux:/ftp/someuser# quota someuser
Disk quotas for user someuser (uid 32070):
Filesystem blocks quota limit grace files quota limit grace
/dev/sdb1 10334 10500 12000 9 0 0
11:30 bourbon-ttyp2 nvlinux:/ftp/someuser#dd if=/dev/zero of=somefile
1000+0 records in
1000+0 records out
11:30 bourbon-ttyp2 nvlinux:/ftp/someuser#chown someuser somefile
11:30 bourbon-ttyp2 nvlinux:/ftp/someuser#quota someuser
Disk quotas for user someuser (uid 32070):
Filesystem blocks quota limit grace files quota limit grace
/dev/sdb1 10837* 10500 12000 none 10 0 0

I tried regenerating the quota.user file from scratch, and got
the same results.
I tried to increase the quota for this user, and then exceed it again -
again, got no grace at all.
I even tried to change the uid for this user to 32071 (and chowning all of
his files and giving him the same quota specs) - nada, the kernel simply
'remembered' it hates him and gave me the same result :)

Now, there are about 15 users that are between their quota and their limit
on the system, about half of them were given the 21-day grace period and
the other half wasn't. If anybody feels they can clue me in as to why
it's happening, I'd be grateful.

Relevant technical information - Linux 2.0.30, ext2 filesystem and (I
don't know if it's relevant) quota package 1.55 (redhat 4.2).

Zeev Suraski <bourbon@netvision.net.il>
Web developer
NetVision, Ltd.     Tel:  +972-4-8560600
Haifa 31015         Fax:  +972-4-8550345

For a PGP public key, finger bourbon@netvision.net.il