New Tulip driver - was: Tulip driver & 2.0.30-pre-patch-2

Russell Coker - mailing lists account (
Mon, 14 Jul 97 11:44:55 +1100

>> I recently tried the 2.0.30-pre-patch-2 which was available
>> on under davem's directory, and have a little
>> "complaint" to make about it.

>Don't mean to be picky, but:

>> Jul 11 05:16:51 aitsu kernel: tulip.c:v0.76 4/22/97 becker@cesdis.gsfc.nasa.go
>> Jul 11 05:16:51 aitsu kernel: eth0: DEC 21041 Tulip at 0x6000, 21041 mode, 00
>c0 f0 15 f8 47, IRQ 10
>> Jul 11 05:16:51 aitsu kernel: THIS IS AN ALPHA TEST DRIVER.
>> Jul 11 05:16:52 aitsu kernel: eth0:21041 Media information at 30, default medi
>a 0800 (Autosense).
>> Jul 11 05:16:52 aitsu kernel: eth0: 21041 media 00 (10baseT), csr13 0004 csr1
>4 0000 csr15 0000.
>> Jul 11 05:16:52 aitsu kernel: eth0: 21041 media 00 (10baseT), csr13 0000 csr1
>4 0000 csr15 0000.

>It's an alpha test driver.
>It blows out for me under 2.1 also.
>Use de4x5 instead for now.
>Or simply copy the old tulip driver from 2.0.30 into 2.0.31.

>In all honesty, I don't really think it should be put into 2.0 just yet.
>I've got an SMC EtherPower and the new driver doesn't like it at all.

FWIW I've tried that driver in a few machines in 2.1 as well as in 2.0.
For 2.1 I had to implement a minor patch to change set_bit() to
test_and_set_bit() (or something similar). For 2.0 I just copied it over
the driver that came with 2.0.30.

I have found that it seems to work perfectly in a Pentium with a 100Mb
21142 card (running as a Squid cache and SMB file server for a Win95
network). Every time I tried it with an older card (21040/21041) it gave
an Oops on ifconfig and made the machine mostly unusable (everything was
fine until ifconfig).

Does anyone have a concise explanation of the difference between the
Tulip and De4x5 drivers? The description in the Documentation directory
isn't very helpful (and doesn't match what people are doing with those

Russell Coker