2.1.79 + latest smbfs patch

David Burrows (snadge@gemcorp.com.au)
Fri, 16 Jan 1998 16:53:25 +1000 (EST)

Its still a no go on my system I'm afraid. I am scratching my head at the
moment as to why some people report success and others don't. I run
RedHat 5 here, which means glibc2, maybe that causes a problem with the
mount tools.. Well I know it does, because I had to fiddle with the
includes to get it to compile. Changed a few things like, where files
caused problems I'd delete the include reference.. and then define what
was missing manually.

Anyway, after all that.. I get a lot of messages like the following and it
still doesn't work.. OSR2 box with winsock2 + exploit updates. (works
fine with smbclient)

smb_proc_readdir_long: name=\*, entries=0, rcls=2, err=1
smb_refill_dircache: readdir failed, result=-23
smb_lookup: find //VBEAF.DRV failed, error=-23

They're the three different types of errors I get on the console.

Now, i've tried "mount mntpoint -f 3755" and it doesn't seem to make any
difference.. but I accidentally tried -t 3755 and smbmnt failed with
"invalid option" so the options are at least getting as far as smbmnt.
Whether they in fact make it to the smbfs module I can't be sure.

Anyone else report success with glibc2/RedHat 5 and 2.1.x smbfs?? Maybe a
RedHat developer might give it a go? :)