Re: gcc-2.8.0 miscompiles kernel (Was: gcc-2.8 out...)

Bernd Nottelmann (nottelm@PTP283.UNI-MUENSTER.DE)
Sat, 17 Jan 1998 19:25:34 +0100

Thomas Pornin wrote:

> Have you tried a 2.1.78 or 2.1.79 kernel ? There was a bug in the de4x5
> driver in the detection code that would trigger a kernel oops on a UDB
> (which has a de4x5 card). I mailed it to the author, who patched it, and the
> patch was included in the 2.1.78 kernel.
> --Thomas Pornin

Thanks for the hint.

I have copied the files de4x5.c and de4x5.h from linux-2.1.79 to
the corresponding directories of 2.0.33.
Unfortunately the kernel stopped the boot process when I
compiled them with egcs-1.0.1.
I solved this problem by compiling de4x5.c with but
I don't know where to find the reason for this bug.
All other parts work normally. :-)

Perhaps does the code-line from the oops-message help? :

Code: f3 a6 74 0a 96 46 80 78 ff 00 75 ed 31 c0 85 c0 74 16 8b 75

My egcs is the haifa-enabled version 1.0.1, the kernel was
compiled with the flags

-O2 -mpentiumpro -malign-loops=0 -malign-jumps=0 -malign-functions=0 -DCPU=686

Hope this helps