Re: devfs

Leonard N. Zubkoff (
Sun, 18 Jan 1998 01:13:44 -0800

Date: Sun, 18 Jan 1998 15:41:57 +1100
From: Richard Gooch <rgooch@atnf.CSIRO.AU>

It does seem inconsistent to have letters delimiting all the other
parameters except the slices. If you can come up with a different
letter for "slice" which doesn't sound too contrived, I'd prefer
that. Right now 's' could be either "subdevice" or "slice". One could
use 'l' for discLabel, but that looks too much like '1'.

While I perfer the more abstract device/subdevice concept to the more specific
device/partition/slice proposal, device/subdevice is not really general enough
to handle slices within partitions without using a contrived subdevice
encoding. I don't have a reasonable suggestion to offer for extending it ("k"
for contrived, anyone? :-)), so it looks like using device/partition/slice is
the best we're going to do.