[offtopic?] 6x86MX Problems

Shane Anderson (shane.anderson@infrasol.com)
Fri, 23 Jan 1998 11:35:04 -0600

This may or may not be offtopic, depending on if this is kernel
related or hardware related (or both.) Here's my deal:

Running a nice PA-2007 AT motherboard w/ 1MB cache and a Cyrix 6x86
200MX latest revision. I run the CPU at the suggested 75MHz bus and
x2 internal multiplier. Seems to run pretty well. Problem is that
my Linux machine crashes after some time--anywhere between 1 and 4
days. At first I thought it might be a bad heat-sink/fan so I got a
better one. Still crashed after 2 days. Here's how it crashes:

I get oopses for kernel NULL pointers, and kernel paging
requests. This happens in various processes (not just one
particular one.) Often times its an inetd run daemon, and sometimes
it's inetd as well. Finally something oopses in the right(wrong)
place and the machine hangs.

I've had better luck with an Intel P150 running at the same clock
speed (75MHz w/ 2x internal multiplier.) Note that this is
overclocked. I'm trying to simulate as similar of conditions as when
the Cyrix is in the CPU socket.

Here's some of my theories so far:

* The PA-2007 motherboard runs the PCI bus at bus-speed/2 always. So
I'm running a 37.5MHz PCI bus. Since my disk access is through a
Buslogic 946C it might be marginal and give me bad data. It's odd
though that the machine runs for 1-4 days before crashing. It could
also be my DEC 21040 ethernet card too. (or even video, but I've
been running a simple text console...)

* BogoMIPS for the 6x86MX are (in theory) misreported. I've played
with the 6x86MX kernel patch, but the BogoMips are still 119 or so
when the utilities say it should be 146 or so. Maybe this pushes the
timing for the theory above to an even more marginal state--the Intel
doesn't have misreported BogoMIPS.

One other odd thing. I run RedHat 5.0 and in my years of experience
with Linux/Slackware/RedHat I've never known the console to have
carriage returns sent to it in a seemingly random fashion. I even
see this on bootup after klog/syslogd start. I have to assume that
empty kernel messages are being sent to the console. I see lots of
this behavior soon after I start getting oopses. I thought that this
might be SCSI messages which have been 'removed' because I didn't
compile the more verbose SCSI messages into the kernel.

BTW: I am running a 2.0.33 stock kernel (w/ just my needed drivers).

Well, I've said a lot. I'm hoping that someone out there has either
run into the same problem. I'm pretty sure it's not the processor
itself. I've ran the distributed RC5DES client for a day on it
without an oops as well as a zillion other apps (slight exageration).
And maybe the BogoMIP thing could turn out the be the problem?
Or the higher PCI bus speed. That'd be a real bummer, since I
purchased this motherboard and the Cyrix 6x86MX just for this

Maybe my next test (*SIGH*) will be to run at 66MHz x2 and see if it
crashes within a week..

-= shane.anderson@infrasol.com ======== Infrared Solutions, Inc. =-