Apparently SOLVED: Linux networking freezes in ~2.1.90-2.1.102

Adam J. Richter (
Sun, 17 May 1998 02:30:18 -0700

The problem that I was experiencing where my telnet sessions
from my home notebook computer to my office workstation would freeze
went away when I fixed a problem with SLIP maximum transfer unit (MTU)
being set differently on my home computer and the modem server that it
was connected to. I would like to thank Pavel Machek for suggesting
that the idea that this was MTU problem. I would also like to thank
David Miller for his help in isolating this problem.

My office workstation still should not have locked up hard
under those circumstances, and there is a question of why the 486
machine that I would use for running tcpdump would complain about "too
much work at interrupt" and then eventually lose network connectivity.
I suspect that the hard lockups will have to remain a mystery for
now (and they may have done away in the 101->102 changes; I have not
tried to reproduce the problem under 102). The tcpdump problem may
just be a function of trying to tcpdump a busy 100mbps ethernet from
a 486.

Anyhow, I just want to report that the problem that I
originally experienced does not occur anymore.

Adam J. Richter     __     ______________   4880 Stevens Creek Blvd, Suite 205     \ /                  San Jose, California 95129-1034
+1 408 261-6630         | g g d r a s i l   United States of America
fax +1 408 261-6631      "Free Software For The Rest Of Us."

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to