2.1.102 problems: sound driver and power mgmt...

Geoff Hardy (ghardy@biztravel.com)
Mon, 18 May 1998 13:13:44 -0400 (EDT)

I apologize if this is redundant or naive, but I'm new to this list.
I'm trying to get an AWE64 card to work in 2.1.102, and I've had a few
problems that people may want to know about.

1. When configuring, I found that the Config.in file in the lowlevel
directory was missing. I re-constructed manually, but I don't know if I
got it right. (This may be the cause of problem 2 below -- I'll check
into it).

2. The kernel built okay with the added Config.in file, but
modprobe/insmod complained about unresolved symbols when I tried to load
it. The symbols appeared to be from ./drivers/sound/lowlevel/init.c:

> sound_init_lowlevel_drivers()
> sound_unload_lowlevel_drivers()

Could it be that these symbols aren't getting exported? I plan to look
into it more tonight, but I'd appreciate any comments or advice on where
to look.

Another unrelated problem:

** I enabled Advanced power management, which caused a compile error for
the file './kernel/time.c'. Disabling APM fixed it, so I thought you
might want to know.


Geoff Hardy

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu