Re: "Segmentation fault" with isapnptools and glibc-2.0.6

Patpong Wetyanon (
Tue, 19 May 1998 19:50:54 +0700 (ICT)

I am not is this can help. I faced the problem of segmentation fault
while running isaconfig if I compile kernel 2.0.34pre15 with gcc-2.8.1
I fix it by changing file ioport.c in arch/i386/kernel to the version
that come with 2.1.100 , it work just fine even I compile with option
-O6 and -mpentium . I am using redhat 5.0 glibc 2.0.6

take care,
On Mon, 18 May 1998, Dominik Stadler wrote:

> Hi,
> I don't know if it's a silly question, but I can't figure it out myself,
> so..
> I'm was using isapnptools with my SUSE-Linux 5.2 to activate a SB
> AWE64-PNP-Soundcard with with no problems at all
> recently I've upgraded to glibc-2.0.6 and now I get a "Segmentation
> fault" or something like that, evertime i run isapnp or pnpdump.
> I've tried to recompile the tools, but no change...
> I've traced the problem and found out, that the first call to "outb" in
> pnpdump is causing the error. I checked that iopl(3) is successfully
> called before "outb" so there can't be too low io-privileges.
> So my question: what am I doing wrong, or what could be the cause of my
> error
> Thanks.
> Dschau..Dominik

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to