Re: Upgrading to a test kernel

Kelley L. (
Fri, 22 May 1998 04:47:39 -0400 (EDT)

On Fri, 22 May 1998, Michael J. McGillick wrote:

> Hello:
> Looking for some help from the Red Hat users on this list (or knowledgable
> others). I've tried a couple of times before to upgrade my existing RH 5.0
> system to one of the test kernels, but I usually end up screwing up one
> thing or another. I have read the documentation, and I've tried
> to upgrade almost of the packages necessary as listed by the minimum
> version numbers in the documentation.
> If anyone is currently running RH 5.0, and has successfully gotten to the
> point of running a test kernel, I would like to discuss the steps that you
> took to get to that point. I would like to keep the system as RPM'ized as
> possible by upgrading packages with RPMs, but I realize that some packages
> may not be currently available like this. According to my system, here is
> what I have installed as opposed to what the documentation is saying that
> I have:
> Package I Have Required
> ------- ------ --------
> -> Kernel modules modutils-2.1.55-4 modutils-2.1.85

Grap all the modutils-*-2.1.85 rpms in the contrib directory, they work

> Gnu C gcc-
You're good to go on that.

> Binutils binutils-

contrib has, I have been using the without any
problems, just upgraded tonight.

> -> Linux C Library libc-5.3.12-25 5.4.44

Stayed with the 5.3.12-25, glibc should take care of this anyway.

> Dynamic Linker ( 1.9.5
Good to go.

> Linux C++ Library libg++-
Good to go.

> Procps procps-1.2.7-1 1.2.7
Need to grab the .src rpm and rebuild if you install the newer
binutils(after you install the newer binutils)

> -> Procinfo procinfo-0.11-1 13
Grab from the contrib dir.

> -> Mount mount-2.7f-1 2.7l
contrib again.

> -> Net-tools net-tools-1.33-4 1.45

Last time I looked, the latest in contrib was 1.432, it is OK, mostly a
cosmetic problem on the display, I believe, functionally OK.(I am almost

> -> Loadlin not installed 1.6a
Not necessary if using LILO.

> Sh-utils sh-utils-1.16-8 1.16
Good to go.

> Autofs 0.3.14 0.3.11
Not using, but it is in contrib also.

> -> NFS not installed 0.4.21
Not using, don't know.

> Bash bash-1.14.7-6 1.14.7
Good to go.

> -> Ncpfs ncpfs-2.0.11-3 2.2.0
Don't know about that one. ;( (there is one in contrib)

> -> Pcmcia-cs pcmcia-cs-2.9.12-4 3.0.1
Not using, don't know. (contrib has it)

> -> PPP ppp-2.3.3-2 2.3.5
Not using, (as usual contrib has it)

> All of the packages with arrows next to them look like they need to have
> newer versions installed. If I install the newer version, will it not
> allow my existing 2.0.34 kernel to work properly? Is there a way to have
> both kernels working on the system, without having to repartition the
> drive?

Both should work just fine, they did for me, (I've haven't used the 2.0.x
series for a while, but I did and had no problems.

Also, I've heard folks talking about gcc, pgcc and egcs. I'm
> assuming that these are all C compilers, but what's up with them? I
> thought gcc was the compiler that we currently use. Is there a movement
> underway to switch to a new standard C compiler for Linux?

I'll pass on that one, I stay confused on a lot of those conversations

> Any help would really be appreciated.
> - Mike

I would just try upgrading all the packages(one at a time, or just go
for the whole ball of wax), and see if anything breaks,
I don't believe it will.

I think you should be able to join the fray, quite easily with
RedHat 5.0, without a lot of problems, and stay totally with RPMs.

Good luck.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to