Welcome to my DHCP nightmare:

Michael J. McGillick (mike@dungeon.ne.mediaone.net)
Fri, 22 May 1998 23:23:41 -0400 (EDT)


Well, with the help of several people on this list, I managed to get the
2.1.103 kernel installed. My system boots, and nothing too much out of
the ordinary has happened. My only problem is my eth0 is no longer
establishing a connection to my ISP.

To begin with, I installed Red Hat 5.0. It worked right out of the box.
I went into the control panel utility under X, and told my system that I
wanted the eth0 device to be activated at boot time, and via DHCP. I
saved the configuration, rebooted, and voila, got a connection. Works
great. This is version 0.65 of dhcpcd.

Next, I configured my system to be able to run the 2.1.103 kernel, and
provided a dual boot so that I could get back into 2.0.34 if I needed to.
I configured the kernel with networking, etc. and told the kernel that I
have the DEC Tulip ethernet card, just like I've done before. I
recompiled, rebooted, and alas, no connection under 2.1.103.

Well, from some more friendly people on this list, the general response
was that I needed to upgrade my version of dhcpcd to 1.3x. I downloaded
the dhcpcd-1.33.src.rpm, and built the rpm for my system. I installed it,
and the system didn't complain. I rebooted, and still no connection
under 2.1.103. Grrrr.

Well, to check, I rebooted into 2.0.34. Funny, no connection here either.
I removed the newer version of dhcpcd, reinstalled the original version,
rebooted into 2.0.34, and my system is back up and running fine. I could
really use some help here, as I am baffled by what has happened. I want
to get this up and working on 2.1.103 and would appreciate any help in
this regards.

- Mike

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu