Re: mdelay() implementation patch

Jamie Lokier (
Sat, 23 May 1998 21:59:50 +0100

> I'd say it reduces confusion and makes the source more readable. For
> example, consider the two functionally equivalent calls:
> udelay(1000000);
> and
> mdelay(1000);
> and then tell me that you don't have to count the zeros in the former
> after staring at a terminal for a few hours. (Yes, you could use
> 1000*1000 to improve readability instead, if you were so inclined...)

`udelay' vs. `mdelay' is a lot easier to miss after a few hours staring, IMO.
If you must have `mdelay', I strongly suggest using a more distinct name.
Can't think of one I like though.

-- Jamie

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to