Re: Kernel lockups with 2.0.3x

Mike A. Harris (
Sat, 25 Jul 1998 20:40:14 -0400 (EDT)

On Sun, 26 Jul 1998, Alan Cox wrote:

> > trouble, however, once I start up X, that is when the trouble
> > starts - well... maybe.. maybe not... I have used X for 3 days
> > straight and not had a lockup or screwup. But now and then, I
> > get a number of freezups. At first, they were fixable by
> > shutting down X and restarting, now my system goes totally dead.
> But you need to run X to trigger it. That pretty much has to be
> either an X11 or hardware bug

Yes, there are no problems whatsoever without X running.
Previous versions of X didn't exhibit this behaviour. As a
matter of fact, I don't believe I experienced this behaviour
until I upgraded to RedHat 5.1.

> > noise. I must assume that the machine totally locked. There is
> > nothing written about the incident in any of the files under
> > /var/log.
> (Seeing if it answers network traffic is a good bet)

Yeah, I tried to telnet, ping, mount nfs, ftp, nothing. Dead as
a doornail. ;o(

> > when the screen twisted, displayed a screwed up KDE desktop, and
> > then locked hard.
> Well yes, I agree with your opinion about the KDE desktop (ok that was cheap)

Heheheh. ;o)

> When you say "screwed up" how do you mean

The entire screen was shifted a random amount to either the left
or the right (depending on how you look at it. The bottom 2
inches went black, with the odd random colored pixels showing up
here and there, in diagonal lines - not straight lines though,
roughly diagonal, and equally spaced every so many cm on the
screen at the bottom. A couple windows were only partially drawn
on the screen (partially updated). The X cursor was on the
desktop, but froze. My mouse and keyboard were totally dead. No
LED's either... A couple other black patches were here and there
on the screen.

> > I tried to telnet in from my 486 over PLIP, and couldn't connect.
> > No ping either.
> Ok. That froze
> That does all sound like hardware or X or combination problems rather
> than Linux.

I've got a 486 here that I've got similarly configured, but with
totally different hardware - it locks the same way... I think it
is X myself...

> Some suggestions to help pin it down:
> o If you have a spare video card or one you can swap with another
> box then swap it and see what occurs

I've done this before, but I will do so with several different
cards from different manufacturers and see what happens.

> o Leave the box contiually doing things for 2 or 3 days and see it
> it dies - the rc5 cracking client will let you do something 'useful' ;) as that. THis will keep the CPU warm..

I will do so.

> o Run badblocks over all your disks. I doubt very much you are seeing
> a disk crash caused by a badblock thats either deep in your swap
> or in something like an X font file but it pays to check

Hmm, that would be a nasty one! I am using a SMART capable drive
(Quantum Fireball SE) that reports no trouble, and any diags say
everything is fine. If I had an easy way of backing up my drive,
I could test it with badblocks like that, but right now it isn't
an option. ;o( I'm planning on getting a new 6.xG though so
maybe then I can try it.

> o If you have RH 5.0 handy run metroX instead of XFree and see what
> happens. Just that varying the X server may give clues

That is a great idea. What is the latest version of MetroX? I
had a licensed version on and Infomagic CD I think... I will try
and find it and try that out.

Thanks for your prompt reply Alan. Keep up the good work!

Mike A. Harris  -  Computer Consultant  -  Linux advocate

Escape from the confines of Microsoft's operating systems and push your PC to it's limits with LINUX - a real OS.

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to Please read the FAQ at