Re: PATCH: combo 30,000fd, 2Gig swap, dynamic superblock, async I/O patch

Anders Melchiorsen (
27 Jul 1998 23:42:31 +0200 (Alan Cox) writes:

> > I get an error in drivers/char/tty_io.c about fasync_helper() being of
> > wrong type, and it is. It seems like all the calls to the function
> > have changed prototype but the function itself is the same?
> Oops well caught. I think the following will fix it.

It made the code compile and run, but when I started X, XEmacs did not
open (I had been running XEmacs on the console before that, no problem).

When I manually tried to start XEmacs it got a segmentation
fault. Now, this might be due to a bug in XEmacs which the new kernel
shows, I guess. Really, I have no idea - but I am not going on without
XEmacs, so I reverted the patch.

What kind of debugging information can be of help in a situation like
this? I did an strace but it seems like I redirected it to somewhere I
cannot locate now :-(. The last call was something with |ASYNC or'ed
in the arguments, I think. Not much help, I know. Before I run the bad
kernel again I would like to know what other information might be

Regards, Anders
(address is valid)

Glory may be fleeting, but obscurity is forever.

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to Please read the FAQ at