2.1.112 Hard lockup on boot with smp

Kevin Fenzi (kevin@scrye.com)
Tue, 28 Jul 1998 21:02:37 -0600 (MDT)

Hi all...Hopefully this report will be worthwile.

I have a dual p166 box that has been happily using the devel kernels
since about 2.1.90 or so. It was running 2.1.111 just fine.

This evening I upgraded it to 2.1.112.

It hard locks on boot up (by hard lock I mean, I have to use the power
switch to reboot it...cntl-alt-del fails, as does the magic sysrq
keys, as does the reset button).

It does provide an oops when it locks. Here is what I managed to copy
down by hand from the screen (man! haven't done that much handwriting
for a long time. ;)

Total of 2 processors activated (132.92 BogoMIPS)
enabling Symetric IO Mode...Done
Init IO_APIC pin 0 Not connected.
Unable to handle Kernel paging request at virtual address c8800288
current->tss.cr3 = 00101000, %cr3 = 00101000
*pde = 0009d063
*pte = 0009c061
Oops: 0003
CPU: 0
EIP: 0010:[<c02214b4>]
EFLAGS: 00010202
eax: 0010c008 ebx: 00000051 ecx: c8800000 edx: c0108e00
esi: 00000000 edi: c020b4f0 ebp: 03f61000 esp: c0107f90
ds: 0018 es: 0018 ss: 0018
Process swapper (pid:0, process nr:0, stackpage=c0107000
Stack: 03f619c4 0000005c 00000002 c02231bc c0223ff8 c03f0044 0009e200 c8000000
000000a0 c0220295 00000002 00000001 c0220945 c0220ac6 c01dce4a c03f0044
c8000000 c03f0044 c8000000 00000000 0009e200 c0106000 00000000 c020b738
Call Trace: [<c01dce4a>] [<c0106000>] [<c01001b4>]
Code: 89 04 d9 89 54 d9 04 46 83 fe 3f 7e d3 5b 5e 5f c3 00 00 00
Kernel Panic: attempted to kill the idle task!
In swapper task - not syncing

I tried to run this through ksymoops, but it doesn't want to do
anything with it:

rahl# cat rahl.oops | ./ksymoops /boot/System.map-2.1.112
Using `/boot/System.map-2.1.112' to map addresses to symbols.

Cannot read eip address from EIP: line. Is this a valid oops file?

I tried booting it about 5 times and confirmed the EIP line really
does look like that everytime. ;(

I would be happy to try any patches or provide any additional
information to anyone. Until then, I have the machine happily booted
in 2.1.111 for now.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.altern.org/andrebalsa/doc/lkml-faq.html