SANE and Kernels 2.1.127-130

Craig Condit (
Tue, 01 Dec 1998 08:36:06 -0600

I have been having some difficulty getting my scanner to operate
correctly with the recent kernels. I have a UMAX Astra 610S flatbed
scanner connected to an Adaptec 2910 controller (AIC-7850). This
combination worked flawlessly under 2.0.34, 2.0.35, and 2.1.125.
Unfortunately, something happened either in 2.1.126 (which I didn't
run), or 2.1.127 which broke SANE. If I do a preview, the scanner locks
up about halfway down the page, and also locks the application. Under
kernel 2.1.129 I actually had a system lock up after attempting to
access the scanner again.

I have tried this using all the above kernel versions, and with SANE
0.74 and the recently released SANE 1.0. I don't know what is causing
the problem, and the system logs do not indicate a problem. I suspect
the problem may lie in the SCSI generic code in the kernel, or in the
ever-changing Adaptec aic7xxx driver.

System information:
Intel 440TX chipset with Pentium 233/MMX, 64 MB RAM, 3 IDE HDD's.

SCSI information: Adaptec 2910 (AIC-7850) ID 2 - Panasonic 7502B CD-R (internal) ID 4 - Iomega ZIP 100 (internal) ID 6 - UMAX Astra 610S Scanner


If anyone has any insight into this issue, please let me know. Also, please CC: my email as I am not a kernel-list subscriber.

Craig Condit

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to Please read the FAQ at