Oops in 2.1.131 accessing IDE CD-ROM

Richard Gooch (rgooch@atnf.csiro.au)
Sat, 5 Dec 1998 12:53:59 +1100

Hi, all. I've been getting Oopses on a new laptop (Dell Inspiron
3200) when I attempt to mount the CD-ROM drive. I noticed the problem
with 2.1.129, 2.1.130 and now 2.1.131. At first, I had the ide-cd and
isofs code compiled as modules, and just now I've tried with them
built in. Still no good. Kernel log and trace follows.

Test patches will be gratefully accepted :-)

Linux version 2.1.131 (rgooch@mobilix) (gcc version 2.7.2.f.1) #3 Sat Dec 5 12:30:24 EST 1998
Detected 232530658 Hz processor.
Console: colour VGA+ 80x50
Calibrating delay loop... 231.83 BogoMIPS
Memory: 79376k/81920k available (876k kernel code, 404k reserved, 1188k data, 76k init)
CPU: Intel Pentium II (Deschutes) stepping 02
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.26 (19981001) Richard Gooch (rgooch@atnf.csiro.au)
PCI: PCI BIOS revision 2.10 entry at 0xfda13
PCI: Probing PCI hardware
PCI: Enabling I/O for device 00:3a
Swansea University Computer Society NET3.039 for Linux 2.1
NET3: Unix domain sockets 0.16 for Linux NET3.038.
Swansea University Computer Society TCP/IP for NET3.037
IP Protocols: ICMP, UDP, TCP
Starting kswapd v 1.5
Serial driver version 4.26 with SHARE_IRQ enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.7)
Real Time Clock Driver v1.09
RAM disk driver initialized: 16 RAM disks of 8192K size
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xfcf0-0xfcf7, BIOS settings: hda:DMA, hdb:pio
ide1: BM-DMA at 0xfcf8-0xfcff, BIOS settings: hdc:pio, hdd:pio
hda: FUJITSU MHD2032AT, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: FUJITSU MHD2032AT, 3102MB w/0kB Cache, CHS=788/128/63, UDMA
hdc: ATAPI 24X CDROM drive, 128kB Cache
Uniform CDROM driver Revision: 2.50
scsi : 0 hosts.
scsi : detected total.
Partition check:
/dev/ide/hd/c0b0t0u0: p1 p2 p3 p4 < p5 p6 p7 p8 p9 >
devfs: v0.55 (19981205) Richard Gooch (rgooch@atnf.csiro.au)
devfs: devfs_debug: 0x0
devfs: boot_options: 0xc
VFS: Mounted root (ext2 filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 76k freed
inserting floppy driver for 2.1.131
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
ad1848/cs4248 codec driver Copyright (C) by Hannu Savolainen 1993-1996
YM3812 and OPL-3 driver Copyright (C) by Hannu Savolainen, Rob Hooft 1993-1996
Linux PCMCIA Card Services 3.0.6
kernel build: 2.1.131 #2 Sat Dec 5 12:01:19 EST 1998
options: [pci] [cardbus] [apm]
Intel PCIC probe:
TI 1131 PCI-to-CardBus at bus 0 slot 4, mem 0x68000000, 2 sockets
host opts [0]: [pci + serial irq] [no pci irq] [lat 168/176] [bus 32/34]
host opts [1]: [pci + serial irq] [no pci irq] [lat 168/176] [bus 35/37]
ISA irqs (scanned) = 3,4,7,9,10,11 status change on irq 11
cs: IO port probe 0x0100-0x03ff: excluding 0x220-0x22f 0x378-0x37f
cs: memory probe 0xa0000000-0xa0ffffff: clean.
eth0: NE2000 Compatible: port 0x300, irq 3, hw_addr 00:40:33:9A:22:26
Unable to handle kernel NULL pointer dereference at virtual address 00000014
current->tss.cr3 = 04a32000, %cr3 = 04a32000
*pde = 00000000
Oops: 0000
CPU: 0
EIP: 0010:[<c0143efb>]
EFLAGS: 00010296
eax: 00000000 ebx: 00001600 ecx: c01e1fcc edx: 00000016
esi: c4643800 edi: c4641600 ebp: 00000016 esp: c495dd68
ds: 0018 es: 0018 ss: 0018
Process mount (pid: 199, process nr: 16, stackpage=c495d000)
Stack: c4643800 00001600 00000000 c01f2000 c0110ae7 c495dd9c fffffc18 c495c000
c01f2000 c495c000 c495dde4 c495ddb0 ffff7f16 c495ddb8 00000202 c495dde4
c495de14 00000000 c495c000 c495dde8 c0006c20 c01bbec8 c495dde4 c0006c20
Call Trace: [<c0110ae7>] [<c01bbec8>] [<c0177b67>] [<c0124fb6>] [<c0144038>] [<c0144051>] [<c0120000>]
[<c01279ea>] [<c0127e9f>] [<c01c4fa4>] [<c0128401>] [<c01c4fa4>] [<c0109864>]
Code: 83 78 14 00 74 5e bb 00 e0 ff ff 21 e3 8b 73 0c 66 89 7c 24

Using `../System.map' to map addresses to symbols.

>>EIP: c0143efb <isofs_get_last_session+2b/a0>
Trace: c0110ae7 <schedule+1e3/20c>
Trace: c01bbec8 <__down_failed+8/10>
Trace: c0177b67 <cdrom_queue_packet_command+47/e8>
Trace: c0124fb6 <set_blocksize+a6/178>
Trace: c0144038 <isofs_read_super+c8/648>
Trace: c0144051 <isofs_read_super+e1/648>
Trace: c0120000 <swap_out_vma+28c/490>
Trace: c01279ea <read_super+86/ac>
Trace: c0127e9f <do_mount+9b/108>
Trace: c01c4fa4 <tvecs+4e20/4ffc>
Trace: c0128401 <sys_mount+2f9/35c>
Trace: c01c4fa4 <tvecs+4e20/4ffc>
Trace: c0109864 <system_call+34/40>
Code: c0143efb <isofs_get_last_session+2b/a0>
Code: c0143efb <isofs_get_last_session+2b/a0> 83 78 14 00 cmpl $0x0,0x14(%eax)
Code: c0143eff <isofs_get_last_session+2f/a0> 74 5e je c0143f5f <isofs_get_last_session+8f/a0>
Code: c0143f01 <isofs_get_last_session+31/a0> bb 00 e0 ff ff movl $0xffffe000,%ebx
Code: c0143f06 <isofs_get_last_session+36/a0> 21 e3 andl %esp,%ebx
Code: c0143f08 <isofs_get_last_session+38/a0> 8b 73 0c movl 0xc(%ebx),%esi
Code: c0143f0b <isofs_get_last_session+3b/a0> 66 89 7c 24 00 movw %di,0x0(%esp,1)
Code: c0143f10 <isofs_get_last_session+40/a0> 90 nop
Code: c0143f11 <isofs_get_last_session+41/a0> 90 nop
Code: c0143f12 <isofs_get_last_session+42/a0> 90 nop



To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.rutgers.edu
Please read the FAQ at http://www.tux.org/lkml/