Re: SMP problem in 2.2.x, not in 2.0.36

Eric Dittman (
Tue, 30 Mar 1999 12:17:48 -0600

>I just bought a new dual PII motherboard (Gigabyte 6BXDS)
>and replaced my old PII motherboard (Gigabyte 6BXC). I
>was using 2.2.1, so I did a make config, turned on SMP,
>and then did a make clean ; make dep ; make bzImage. I
>copied this image over to /boot, added an entry in lilo.conf
>and ran lilo, then rebooted. The new kernel was able to
>detect and use both CPUs, but in X I have to sometimes click
>several times on a window to raise it. I downloaded and built
>2.2.2 and have the same problem.
>I had 2.0.36 still in my source directory, so I build an
>SMP kernel of that and tried it. X had no problems. I
>thought the window manager I was using (WindowMaker) may
>be the problem, so I switched to fvwm. No change. Any
>ideas? This is my first time trying to use Linux SMP.

Okay, I tried 2.2.3 and 2.2.4 and didn't see any improvement.
With 2.2.5 I find I usually only have to click a couple of
times on a window to raise it, so there is an improvement.

Eric Dittman           Raytheon Systems Company - Component Test Facility                                      (972) 462-4292
Disclaimer:  Not even my opinions.  I found them by the side of the road.

- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to Please read the FAQ at