Re: Not that again: ping with odd packests fail :-( !!!!

From: Mircea Ciocan (mirceac@interplus.ro)
Date: Fri Jan 14 2000 - 13:18:33 EST


        Hate to reply to my own post but that it:

        It seems to me that the problems is the stock ping command supplied by
Slackware, after grabbing net-tools-base and recompiling with
gcc-2.7.2.3 the ping workas, I'll try the same thing with samba and I'll
keep you informed.
        Sorry for uninformed post. :(

                Mircea C.
Mircea Ciocan wrote:
>
> It seems that this ugly bug raise its head again:
>
> System: PII-333, Slackware 7.0, gcc-2.95.2, kernel 2.2.14 final
> compiled with gcc-2.95.2.
>
> Puzzeld by the strange awfull performance of samba and many lock-ups
> when copying large files, I pinged the host with some 333 bytes size
> packet just by chance.
> I don't answered, of course I tried the "normal" ping and worked, and
> in the end it seems that old bug with odd sized packets showed again.
> Now, I understand that in new kernels the -f no-strict-alias is in
> Makefile, what now must be done to not have to C compilers installed,
> source of great grief and pain :(.
> Come on, if somebody knows WHERE in the kernel is that thing, I'll
> volunteer to do whatever boring and unplesant changes must be done to
> get rid of that crap.
> And I thing that explains a lot of messages on samba mailing list that
> says that when copying large files sometimes the process ends with the
> message "resource not availale" or so.
>
> Desperatly,
>
> Mircea C.
-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu



This archive was generated by hypermail 2b29 : Sat Jan 15 2000 - 21:00:30 EST