2.2.14 and slow TCP/IP

From: Berend De Schouwer (bds@jhb.ucs.co.za)
Date: Mon Jan 24 2000 - 04:09:53 EST


I've seen similar questions in the list, and searched for them, but no
immediate answers arose from following the threads, so I am trying this
again. These questions were for a variety of kernels.

I've got 2.2.14 running on some machines just fine. All of these
machines are single processors (p90 and faster). I've got a problem with
one machine: a dual pentium 133.

When ftp-ing from the smp 133, to another machine (running 2.0.36 or
2.2.14, etc.) over a 100baseT switched network, I get transfers of
approximately 8KB/s - that's 8KB, not 8e+03.

I've tried with a single-processor and smp-enabled kernel. I've tried
modules, and compiled in, and I've tried the "my processor can't handle
the bandwith" option. All the same result.

I've tried a 3c905B, and a eepro100. The eepro100 gives a slightly
different result: its running at about 8e+02KB at best, but it can be
slowed down very easily. The easiest way to slow it down to 8KB is to
run "cat /proc/interrupts" continuously in a different session.

The eth0 interrupt counter increases slowly, indicating that interrupts
seem to get dropped by the driver. The kernels are stock kernel.org
kernels. The IRQs are not shared.

I/O, loadavg, and CPU usage seem minute.

I've tried 2.0.36 on this machine, and it runs at 8e+03KB transfers,
just fine. No hardware or binaries were changed - simply put 2.0.36 on
a stiffy.

Other machines I have tried this on, have dual-processor motherboards,
but only a single processor installed. All are the same make (Acer),
from Pentium 90 through p-pro to Pentium2-400.

-- 
Kind regards,				  
Berend                                  
                                        
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Berend De Schouwer, +27-11-712-1435, UCS

- To unsubscribe from this list: send the line "unsubscribe linux-net" in the body of a message to majordomo@vger.rutgers.edu



This archive was generated by hypermail 2b29 : Mon Jan 31 2000 - 21:00:32 EST