Networking problems with 2.3.41-pre3

From: Petr Vandrovec (VANDROVE@vc.cvut.cz)
Date: Thu Jan 27 2000 - 06:45:16 EST


Hi Dave,
  it is probably well known bug, but I did not see noticed it here, so
I'll ask. Since I'm using 2.3.41-pre3 (with tulip), I'm expriencing TCP
problems. For example, when I was ftping data from vana to vanicka
(Linux 2.3.41-pre3 to Windows98), I'm expriencing
  ftp : get: error 10054
10054 = ECONNRESET
Strange, isn't it (Windows ftp does not know PASV, so I tried only
active ftp mode)? Nothing in syslog, proftpd said
  data_sendfile(8,0,14527071)
  data_sendfile: 14527071
so it is happy. But under windows about last 30KB of file was missing.
And I cannot connect from vana to dialog (2.3.41-pre3 -> 2.2.2) (neither
ssh nor telnet nor socket... ICMP works), I'm getting syslog (on vana)
filled with
  TCP: synsent reject.
Connection vana -> platan -> dialog -> vana (2.3.41-pre3 -> 2.3.33 -> 2.2.2
-> 2.3.41-pre3), it works.
Everything except vana (2.3.41-pre3) are UP machines (Pentium), vana is
dualSMP PIII. dialog, vana and vanicka are connected to 10Mbps ethernet HUB,
platan is 100Mbps beyond switch.
                                            Thanks,
                                                    Petr Vandrovec
                                                    vandrove@vc.cvut.cz
                                                    
-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu



This archive was generated by hypermail 2b29 : Mon Jan 31 2000 - 21:00:33 EST