Unresolved symbols in ipx.o; Linux 2.2.14

From: Chris Rankin (rankinc@zip.com.au)
Date: Sun Jan 30 2000 - 09:03:59 EST


Hi,
I have tried to configure my Linux-2.2.14 kernel with IPX support
because there is a good chance that I'll need to connect to a Netware
4.11 server (with NDS) in the near future. Anyway, after an
unremarkable build (make dep; make clean; make bzImage; make modules;
make modules_install; lilo etc etc) I am getting the following errors:

# depmod -a
depmod: *** Unresolved symbols in /lib/modules/2.2.14/misc/ipx.o
# depmod -e
depmod: *** Unresolved symbols in /lib/modules/2.2.14/misc/ipx.o
depmod: make_EII_client
depmod: make_8023_client
depmod: destroy_8023_client
depmod: destroy_EII_client

According to my System.map file, these symbols are all present:
c014f30c T make_EII_client
c014f340 T destroy_EII_client
...
c014fd90 T make_8023_client
c014fdc4 T destroy_8023_client

However, the /proc/ksyms file looks rather peculiar:
c014fd90 make_8023_client_R__ver_make_8023_client
c014fdc4 destroy_8023_client_R__ver_destroy_8023_client
c014f30c make_EII_client_R__ver_make_EII_client
c014f340 destroy_EII_client_R__ver_destroy_EII_client

All the other symbols have CRC numbers after the "_R" part, so I'm
guessing that this has something to do with it.

On a related note, is the ncpfs package still maintained? I tried to
compile it against glibc-2.1.2 and I had an undefined symbol "NR_OPEN",
which is apparently defined by the kernel headers. There was also
trouble in the include/kernel/types.h file, specifically

#ifdef __GLIBC__
/* why is this defined in posix_types ???? dirty hack... */
#undef __FD_CLR
#undef __FD_SET
#undef __FD_ISSET
#undef __FD_ZERO
#ifdef _SELECTBITS_H
#undef _SELECTBITS_H
#include <selectbits.h>
#endif
#endif

This breaks compilation with glibc-2.1.2; I had to remove it.

Anyway, thanks for any assistance (with the kernel bit),
Cheers,
Chris.
-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu



This archive was generated by hypermail 2b29 : Mon Jan 31 2000 - 21:00:33 EST