Re: [IGMPv3/MLDv2] Problem using host implementation on 2.6.0-test1

From: Hitoshi Asaeda (Hitoshi.Asaeda@sophia.inria.fr)
Date: Fri Jul 25 2003 - 05:38:55 EST


> I used to work under *BSD with Kame's kernel patch (inspired by
> Hitoshi Asaeda's patches) for IGMPv3 and MLDv2 host implementations,
> and t worked (not perfect but sufficient).

Personally, I'm really interested in "which part is not perfect?".:)
(I've not checked all KAME codes, though.)

> When i take a look at the kernel sources, i can find the structures
> im supposed to use, which are both the IP independent ones, such as
> struct group_req or struct group_source_req or the operation codes
> such as MCAST_JOIN_GROUP, MCAST_JOIN_SOURCE_GROUP....., and the
> protocol specific ones, such as struct ipv6_mreq or struct
> ip_mreq_source, but i only find the protocol specific ones in
> /usr/include once the kernel is installed.

I've just checked /usr/include/linux of 2.6.0-test1.
There are the definitions, e.g. MCAST_JOIN_SOURCE_GROUP, in in.h.
Is it your answer?

But anyway, why e.g. struct ip_mreq_source defines each data to __u32
type, not struct in_addr? The MSF I-D explicitly mentions they are
struct in_addr.

> I tride to define the protocol independent ones manually, it builds,
> but when running i have the following error when trying to join a
> channel :
>
> join_leave_ssm setsockopt : No such file or directory
>
> I knew i would have an error, but i don't understand much....
> When using the protocol specific ones, it get a problem with the
> interface : if i give the correct interface address or the generic
> INADDR_ANY or in6addr_any i get the same error :
>
> join_leave_ssm setsockopt : No such device

In fact, I tried to know the interoperability with Linux's
implementations on 2.4.22-pre1.
But I got a same error (No such device) when I just tried to join
(S,G). I don't know how different there is in 2.6.0-test1, though.

--
Hitoshi Asaeda
-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html



This archive was generated by hypermail 2b29 : Thu Jul 31 2003 - 22:00:01 EST