TCP issues

From: warrier
Date: Tue Apr 12 2005 - 18:37:43 EST


Hello
I'm having some problems with TCP/IP connections on a linux kernel
version 2.4.25.

I'm communicating between two power pc based cards and using tcpdump I've
worked out the scenario that takes place.

One of the cards has a Motorola (Freescale) 5200 as the CPU and the other
has an MC8270. The 8270 is more powerful than the 5200.

If I try to ftp a file that is larger than 7K from the 5200 to the 8270
around 7000 bytes get copied over and the the ftp connection hangs.
If I run netstat I see that it is in the ESTABLISHED state.

However no further data transfer takes place.

Using tcpdump I've noticed that one packet does not seem to have made its
way to the 8270 because the sequence numbers are off by one packet size.
The 5200 continues to send packets while the 8270 sends acknowledgements
with the sequence number it expects. After some transmissions the 5200
sends the missing packet.
However the 8270 does not send an ACK.
This scenario then continues for a long time and I have to terminate the
connection.

FTP is one way of reproducing it but I have seen it happen with ordinary
programs too.

Has anybody come across a problem like this? Is there a solution. Both
these cards are part of an embedded chassis.


Thanks

S
-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html