Re: Connecting Motorola cellular phones over USB with P2K using moto4lin

From: David Harel
Date: Sun Jan 03 2010 - 15:44:31 EST


Sorry for the long delay (who connects his phone that often?).

Charlie Brady wrote:


On Sun, 15 Nov 2009, David Harel wrote:

Greetings,

I use Linux Ubuntu Jaunty 9.04 kernel 2.6.28-16-generic to connect my
Motorola phones.
I have to do that while logged in as root and it connects nicely using
AT over ttyACM
/dev/usb/ttyACM0
After disconnect I can no longer use this method to connect my phone and
I have to reboot before I can reconnect the phone.

Nobody is likely to be able to help you unless you provide more detail. Why can you "no longer use this method"? What happens when you try? Why do you have to reboot? What other recovery techniques (short of rebooting) have you tried?
It simply hangs on next connect attempts. I don't remember finding anything funny on the log or dmesg. I will be happy to assist. Just give me what you want me to check.


I tried it also on my Gentoo installation (currently kernel
2.6.27-gentoo-r8 and also tried it with two different Motorola phones.
I have this problem for more than a year (obviously it is not something I do very often) and I have been waiting patiently hoping (it sure looks like) a kernel upgrade would resolve this problem.

If it is not a kernel problem then you will be waiting forever.

If connection fails with a different phone and a new process and it is not kernel/driver than I don't know what it is. I would assume that a device would become ready once a new process and new HW gets connected to it. But that's me.

--
Regards.

David Harel,

==================================

Home office +972 77 7657645
Cellular: +972 54 4534502
Snail Mail: Amuka
D.N Merom Hagalil
13802
Israel
Email: hareldvd@xxxxxxxxxxxxxxxx


--
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html