ppp locks machine up solid !

Gary Anderson (ganderson@clark.net)
Sun, 6 Aug 1995 22:38:51 -0400 (EDT)


I mentioned this once before, but didn't get any answers. Now I have a
small shred of additional info to offer. Here's my current setup:
1.2.13 kernel, gcc-2.6.3, libc-4.7.2/5.0.9 (half-way thru ELF
conversion), pppd-2.1.2d. My machine is connected to a service provider via a
ppp link. I telnet'd into my box from somewhere else and did an 'ls' on a
directory. After receiving only the first 3 file names (out of several
dozen), the connection froze. Looked at the console of the linux machine and
saw the following message:

"ppp0: Tx timeout. (presently a no-op)"

This message comes out of drivers/net/ppp.c (ppp_tx_timeout).

The linux box was then frozen solid. Modem was still on line, but my
normal lcp echo pulses were not going out. Could not switch virtual
consoles at all, none of the shift/alt/ctrl - scroll lock combinations
worked, ctrl-alt-del didn't work, and I finally ended up having to
'one-finger-salute' the reset button.
No entries in the kernel log or syslogs at the time of the lock-up.

I also experienced this problem with the 1.2.11 kernel, but never caught
the above kernel message before because the screen blanker apparently
_did_ still work, as the screen was always blank by the time I got to my
machine.

This is a very consistent problem. All I have to do is telnet into my
machine, 'ls' a couple of directory listings, and voila ! Lock-Up !

Hmmm...I just put this message on hold for a bit to try it again. This
time the shift/alt/ctrl - scroll-lock combos worked after the lock-up.
Their info _still_ didn't end up in the kernel log, though. For the most
part, the EIP: value was either 0010:00134fa7 or 0010:00134bbe. Here's the
relative portion from this kernel's System.map:

00134900 T dev_queue_xmit <------
00134bd0 T netif_rx
00134c80 T dev_rint
00134dd0 T dev_transmit
00134e00 T net_bh
00134f50 T dev_tint <------
00134ff0 t dev_ifconf

Other than that, the other symptoms remained the same this time.

Anyone have any thoughts, ideas, speculation ?

Oh - by the way, this problem _does not_ occur when telnet'ing _out_ .

__
********************************************************************************
_/_/_/_/_/ _/_/_/_/_/ _/_/_/_/_/ _/ _/ | Gary Anderson
_/ _/ _/ _/ _/ _/ _/ | ganderson@clark.net
_/ _/_/_/ _/_/_/_/_/ _/_/_/_/_/ _/_/ | --------------------
_/ _/ _/ _/ _/ _/ _/ | finger me for my
_/_/_/_/_/ _/ _/ _/ _/ _/ | pgp public key
********************************************************************************
Just go with the flow control, roll with the crunches, and, when you
get a prompt, type like hell.