Recurring problem with a 3c509 and self-arping

lilo (TaRDiS@mail.utexas.edu)
Thu, 9 May 1996 00:50:22 -0500 (CDT)


I'm having a problem currently which has existed through the late 1.3.x
kernels, AT LEAST. We haven't used this setup until recently though.

Problem: I have two 3c509's connected on a lan. One running on a rather
slow 386sx with a largely-unmodularized kernel works great. The other side
runs on a moderately fast machine with very modular kernel, this machine.
The kernel modularization seems to be the only software difference.

However, on this machine, when I first access the other machine (to ping for
example), this machines associates the other machine's IP address with this
machine's ethernet address. When I do a tcpdump, it appears that our
packets are being sent to and from the same ethernet address (this one),
though the source and destination IP's are what they should be.

On prior kernels I ran before 1.3.99, I got a kernel message that noted that
I was `self-arping', which seemed to jibe with what I was seeing.

Anyway, I'm wondering if anyone has seen anything similar. I run a
production system at work with two interfaces, and am fairly conversant with
the requirements of the ifconfig and route commands, as well as just a
little familiar with arp. We're doing ip aliasing, and it seems to be
working fairly well. I mention this just to note that I'm not a complete
idiot, though I try. ;)

Anyway, if this strikes a chord, let me know. Hopefully I'll have a chance
to delve into it more after finals. It looks as if I'm in no danger of
losing this opportunity through the problem being fixed in a subsequent
kernel.... :)

lilo