YP ERROR

Tohru Yagi (yagi@comm.eng.osaka-u.ac.jp)
Thu, 09 May 1996 15:34:29 +0900


Hello all,

I'm using Linux as a NIS(YP) client. But I have a lot of
errors concerning about YP service. The error is as follows.

YP: server for domain (none) not responding, still trying

This strange error is added to /var/log/cron file almost every 10
seconds!
I thought that this occurs because NIS is NOT set up
correctly. I checked if or not rpc.portmap and ypbind were
working. The programs were running flawlessly and "ypcat passwd"
showed the entire NIS passwd database. This client seems to be
running with no problem EXCEPT FOR THIS ERROR MESSAGE!
And I have another error in booting. This error is also
added to /var/log/cron. The error is

clnttcp_create: RPC: Port mapper failure - RPC: Unable to send

I guess this occurs when I try to nfs-mount the "exported" file
system of a SUN file server. I wonder if the first error and the
second one have something to do with each other.
This Linux client is based on:

Slackware 2.2.0.1
linuxelf-1.2.13(supports ELF)
GCC 2.7.2
LIBC 5.0.9
amd-upl102(used to nfs-mount)

And here is part of process information:

PID TTY STAT TIME COMMAND
1 ? S 0:11 init
6 ? S 0:00 (update)
7 ? S 0:03 update (bdflush)
34 ? S 0:03 /usr/sbin/crond -l10
50 ? S 0:05 /usr/sbin/syslogd
52 ? SW 0:00 (klogd)
57 ? S 0:02 /usr/sbin/rpc.portmap
60 ? S 0:29 /usr/sbin/ypbind
62 ? SW 0:27 (inetd)
64 ? SW 0:04 (lpd)
73 ? S 1:32 /usr/local/sbin/amd -w 180 -l /var/log/amdlog
/net/home /usr/local/etc/amd.net.home -cache:=inc
78 ? S 0:02 sendmail: accepting connections

Does anyone know why these errors occur and how I can
stop them? I appreciate any advices.

Thank you.

Tohru Yagi
Osaka University, JAPAN
E-mail: yagi@comm.eng.osaka-u.ac.jp