Re: Big Linux PPP (and diald) problems (with Demon at least)

Richard Kettlewell (richard@sfere.elmail.co.uk)
Sun, 9 Jun 96 15:42:52 +0100 (BST)


Piercarlo Grandi writes:

>I am using the latest pre2.0.* kernel releases of Linux, with
>diald-0.14, net-tools-1.32-alpha, ppp-2.2.0f, libc-5.4.1, etc., and
>accessing demon with ppp via the 0645 number.
>
>I have a number of rather annoying problems with this setup...
>
>1 For some reason diald issues a 'route' command that fails, even if this
> does not seem to cause functional problems.

I've seen this too; kernel pre2.0.13, diald 0.14 (just upgraded from
0.10 as that didn't work well with the new kernle), ppp 2.2.0e and
2.2.0f (tried upgrading to see if that solved it), libc 5.2.18.
Talking to MST PPP on a Sunos 4.1.3 box at work. My /sbin/route is
from Debian's netbase 2.03-1 package, couldn't say offhand what
upstream version that represents.

Jun 9 15:23:36 sfere diald[578]: Nonzero exit status (1) on command '/sbin/route add default gw 193.122.233.1 metric 2000 dev sl0'

More interestingly I backed off to 1.3.68 and stopped seeing these
messages. Has the kernel interface used by route(8) changed at all
recently?

- Richard

-- 
http://www.elmail.co.uk/staff/richard/
GCS d- s+:- a-- C++ ULVS+++$ P+++ L++ E++ W(++,--) N(++,+) o? K w---
O? M- V? PS(+,+++) PE Y+ PGP+ t- 5++ X+@ R tv--- b++>++++ DI+ D+ G e++
h r% y++