PPP problems

Azathoth (kdoherty@binx.mbhs.edu)
Sun, 9 Jun 1996 21:41:12 -0400 (EDT)


sorry bout that blank message, I meant to cancel it. Anyway, on to my ppp
troubles.

I'm running linux 1.99.12, with ppp-2.2.0f. Now, I can connect to the PPP
server fine, and login. pppd runs and connects fine, as far as I can tell.
But the connection is incredibly slow. Here's a ping output from a ping to
one of the servers on the network:

PING binx.mbhs.edu (192.67.131.1): 56 data bytes
64 bytes from 192.67.131.1: icmp_seq=0 ttl=63 time=89217.6 ms
64 bytes from 192.67.131.1: icmp_seq=1 ttl=63 time=88510.8 ms
64 bytes from 192.67.131.1: icmp_seq=2 ttl=63 time=87570.8 ms
64 bytes from 192.67.131.1: icmp_seq=3 ttl=63 time=86640.7 ms
64 bytes from 192.67.131.1: icmp_seq=4 ttl=63 time=85700.8 ms
64 bytes from 192.67.131.1: icmp_seq=5 ttl=63 time=84770.7 ms
64 bytes from 192.67.131.1: icmp_seq=6 ttl=63 time=83924.2 ms
64 bytes from 192.67.131.1: icmp_seq=7 ttl=63 time=83002.9 ms
64 bytes from 192.67.131.1: icmp_seq=8 ttl=63 time=95030.8 ms
64 bytes from 192.67.131.1: icmp_seq=9 ttl=63 time=113090.9 ms
64 bytes from 192.67.131.1: icmp_seq=10 ttl=63 time=112160.8 ms
64 bytes from 192.67.131.1: icmp_seq=11 ttl=63 time=111220.7 ms
64 bytes from 192.67.131.1: icmp_seq=12 ttl=63 time=110290.8 ms
64 bytes from 192.67.131.1: icmp_seq=13 ttl=63 time=109360.8 ms
64 bytes from 192.67.131.1: icmp_seq=14 ttl=63 time=108420.8 ms
64 bytes from 192.67.131.1: icmp_seq=15 ttl=63 time=107490.8 ms
64 bytes from 192.67.131.1: icmp_seq=16 ttl=63 time=106550.7 ms
64 bytes from 192.67.131.1: icmp_seq=17 ttl=63 time=105980.7 ms

This is extraordinarily high. Now, another odd thing is this syslog
output:

Jun 9 20:43:03 mentos pppd[2326]: pppd 2.2.0 started by root, uid 0
Jun 9 20:43:03 mentos pppd[2326]: Using interface ppp0
Jun 9 20:43:03 mentos pppd[2326]: Connect: ppp0 <--> /dev/modem
Jun 9 20:43:03 mentos pppd[2326]: sent [LCP ConfReq id=0x1 <mru 1500> <magic 0xfce86eba> <pcomp> <accomp>]
Jun 9 20:43:04 mentos pppd[2326]: rcvd [LCP ConfAck id=0x1 <mru 1500> <magic 0xfce86eba> <pcomp> <accomp>]
Jun 9 20:43:05 mentos pppd[2326]: rcvd [LCP ConfReq id=0x2c <asyncmap 0x0> <magic 0x1741973f> <pcomp> <accomp>]
Jun 9 20:43:05 mentos pppd[2326]: sent [LCP ConfAck id=0x2c <asyncmap 0x0> <magic 0x1741973f> <pcomp> <accomp>]
Jun 9 20:43:05 mentos pppd[2326]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <compress VJ 0f 01>]
Jun 9 20:43:08 mentos pppd[2326]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <compress VJ 0f 01>]
Jun 9 20:43:08 mentos pppd[2326]: rcvd [IPCP ConfNak id=0x1 <addr 192.67.131.90>]
Jun 9 20:43:08 mentos pppd[2326]: sent [IPCP ConfReq id=0x2 <addr 192.67.131.90> <compress VJ 0f 01>]
Jun 9 20:43:08 mentos pppd[2326]: rcvd [IPCP ConfReq id=0x2d <compress VJ 0f 01> <addr 192.67.131.50>]
Jun 9 20:43:08 mentos pppd[2326]: sent [IPCP ConfAck id=0x2d <compress VJ 0f 01> <addr 192.67.131.50>]
Jun 9 20:43:08 mentos pppd[2326]: rcvd [IPCP ConfAck id=0x2 <addr 192.67.131.90> <compress VJ 0f 01>]
Jun 9 20:43:08 mentos pppd[2326]: local IP address 192.67.131.90
Jun 9 20:43:08 mentos pppd[2326]: remote IP address 192.67.131.50
Jun 9 20:47:15 mentos pppd[2326]: Hangup (SIGHUP)
Jun 9 20:47:15 mentos pppd[2326]: Modem hangup
Jun 9 20:47:15 mentos pppd[2326]: Connection terminated.
Jun 9 20:47:15 mentos pppd[2326]: Exit.

Now, between the "remote IP address..." stuff and the Hangup, I tried
telnetting to binx.mbhs.edu, and DID get a connection. I also used kdebug
31, which should give me all the kernel debugging stuff, and, unless I'm
mistaken, should output SOMETHING of that connection. I don't know what
could be going wrong. Any help is greatly appreciated. (and sorry again
for the blank message)

mentosmentosmentosmentosmentosmentosmentosmentosmentosmentosmentos
e Kevin Doherty kdoherty@mbhs.edu MBHS Sysadmin m
n "Not dead which eternal lie Metallica - e
t Stranger aeons death may die" The Thing That Should Not Be n
o Mentos: The Freshmaker! t
smentosmentosmentosmentosmentosmentosmentosmentosmentosmentosmento