Re: eth0 mismatched read page ptr

Paul Gortmaker (gpg109@rsphy1.anu.edu.au)
Mon, 10 Jun 1996 13:12:14 +1000 (EST)


> > > The first : the logs hereafter will tell you about it. This bug is present
> > > in all kernels from 1.3.97 to .100. Never noticed it before :
> >
> > Ok 1.3.97 turns on some 8390 performance features. That may be causing
> > the problem. I'll see what Paul has found out (he is looking at a couple
> > of these)

Putting dual Tx bufs back into place didn't happen until 1.3.99, so if
it broke at 1.3.97 it is probably something else. Did 1.3.96 actually
work without the need to hard reset the machine after running win95?

> I just found out something interesting : if I run win95
> before starting linux, the "eth0: mismatched read page pointers..."
> appears after the first ethernet network access...
>
> Jun 9 17:02:31 tower kernel: eth0: mismatched read page pointers 1 vs 4c.
> Jun 9 17:02:31 tower kernel: eth0: mismatched read page pointers 1 vs 4d.
> Jun 9 17:02:31 tower last message repeated 7 times
>
> If I run linux after hard reseting/power cycling my computer,
> there's no problems. The socket destroyed problem also
> disappear...

It sounds like the win95 driver is putting the card in some proprietary
mode of operation from which you can't get back out of unless you cycle
the power. The linux driver does a hard reset of the card upon init, and
there isn't much else it can do if that doesn't bring it back.

If the above is true, you may wish to try throwing the driver disk that
came with the card out the window, and just use the "generic" NE2000
driver that (I suspect) is included with win95.

Paul.