Re: eth0 mismatched read page ptr + Socket destroy delayed

Alexandre Maret (amaret@infomaniak.ch)
Mon, 10 Jun 1996 23:17:38 +0200


Alan Cox wrote:
>
> > If I run linux after hard reseting/power cycling my computer,
> > there's no problems. The socket destroyed problem also
> > disappear...
> >
> > I think the problem is the ne2000 initialization...
>
> Unfortunately its pretty much impossible to fix that. The PC designers forgot
> to arrange a way (other than the off switch or reset button) for resetting
> controller boards. I don't know enough about the NE2000 setup to know if
> we can force the NE2K into a suitably sane state, or if the relevant scheme
> works on all the clones etc ..

okay... but it *worked* before 1.3.97. So it's not impossible
to do... we would have to look at the diffs in the initialization
code. I'm pretty ignorant about all this stuff, so I can't help,
but will hopefully cooperate to help anybody solve this (my?)
problem :-)

alex

-- 
\\-----------------------------------------------------------\\
// Alexandre Maret -- Linux : The choice of a GNU generation //
\\ amaret@infomaniak.ch -- http://www.infomaniak.ch/~amaret  \\
//-----------------------------------------------------------//