Unknown ethernet packets with linux-2.0.0....

Kambiz Aghaiepour (kambiz@tcsi.com)
Thu, 13 Jun 1996 09:37:47 -0700


Sorry for the duplicate message (I sent this from another account once);
please reply to "kambiz@tcsi.com" (this account).

Linux-2.0.0
Western Digital Ethernet Card
Connected via 10BT to an Ascend Pipeline 25 ISDN modem
Note: The externally connected Ascend modem automatically initiated
calls to my local ISP whenever it seems outbound packets.
Also, it configured such that inbound broadcast packets do not
reset the idle timer; this way the connection is dropped after
two minutes of idle time.

Since upgrading to linux-2.0.0 I'm noticing outbound ethernet packets of
an unknown type that are causing the connection to my ISP to go "up".
I've tried to look for the source of the packets using "tcpdump" but
nothing shows up (even though I see that there are occasional packets
initiating the ISDN call).

I've compiled in the packet forwarding/gatewaying option as well as the
masquerading option along with running "ipfwadm" to masquerade all
outbound packets. But I cannot see why there are outbound ethernet
packets coming from my system.

Any ideas on why this might be happening? Is there a "etherdump" or
"etherfind" available for linux? This behavior does not happen with
linux-1.3.30 . I haven't tried any other 1.3.x kernel revs. But I
really need the IP masquerading option.

Thanks in advance.

Kambiz

-- 
\o__O   o        Kambiz Aghaiepour     - |       kambiz@tcsi.com       o   o
  \_   /|\           TCSI Inc.         |\-     -=-=-=-=-=-=-=-=-=-    //\ //\
   |\   |\        2201 Dwight Way,     | |    Voice: (510) 649-3623    //  //
  / /   |/       Berkeley, CA 94704      |    Pager: (510) 849-6133    |\  ||