NE2000 lockup in 2.0.0?

Marek Michalkiewicz (marekm@i17linuxb.ists.pwr.wroc.pl)
Fri, 14 Jun 1996 03:45:37 +0200 (MET DST)


The 2.0.0 kernel works quite well, but I just had one lockup.
I suspect that it might be caused by my cheap old NE2000 clone
(Genius GE-2000, built in 1993, a fairly large card with many
chips on it, not one of these new single-chip cards).

The card has two LEDs on the back: a green one for "power on" and
a red one for "network activity". The system locked up solid, no
messages, no VC switching. There was only very little network
activity at that time. I suspect the card because NE2000 clones
were known to cause problems in the past, and the red LED on the
card (which is normally flashing randomly) was illuminated all
the time (even after disconnecting the T connector from the card).

Note that it happened once so far (it worked fine for several
days with various 1.99.x kernels as well as 2.0.0), so it could
just be a random hardware problem. Especially since I run my
ISA bus at 40/3 = 13.3 MHz (is it possible for a NE2000 to lock
up because of too fast ISA bus speed?).

I'm reporting it just in case it turns out to be a real bug...
Or is the NE2000 such a bad design that it is impossible to
guarantee no lockups no matter how careful is the driver?

Marek