Re: IP Masquerading not working

smwong@cs.cuhk.hk
Mon, 27 Jan 1997 14:10:06 +0800 (HKT)


> Hi. Hope you all can give me a hand here, trying to get ip masquerading
> working. I have a simple setup:
> - PPP connection to the net through my ISP
> - Main computer (redpoint) is a P100 running kernel 2.1.13 with all (as
> far as I can tell) updated libc, libg++ etc. Ip = 192.168.0.1
^^^^^^^^^
> - my second computer (t2) is connected to redpoint via ethernet and has
> my ISP's DNS in /etc/resolv.conf. ip = 192.168.0.2
^^^^^^^^^
>
> Everything works in the local "net" (if this setup could be called that
> <G>). I can ping, ftp, telnet etc from redpoint to t2 and back.
>
> I've compiled ipforwarding, firewalling and masquerading into the kernel
> of the P100, and the modules are loaded via rc.modules. I have the
> following in my rc.local:
> ipfwadm -F -p deny
> ipfwadm -F -a m -S 192.168.2.0/24 -D 0.0.0.0/0
^^^^^^^^^
The above "^^^^^^^^^" don't agree! I wonder whether you can use
192.168.0 as network number, although 192 should be for class C. I
won't use that if possible.

My 2 cents.

-- 
                                                              \//////
Stephen Siu Ming Wong     Internet: stephenwong@cuhk.edu.hk   [ O O ]
Dept of Computer Science              smwong@cs.cuhk.edu.hk    \_-_/
Chinese University of                                          _| |_
Hong Kong                    Pager: 7229-4680                 / \_/ \
____________________________________________________________oOOO___OOOo__