minor progress - At wits end networking two boxes at home

Bjorksten (jimb@austin.ibm.com)
Tue, 28 Jan 1997 08:38:50 -0600


Thanks for the loopback advice, now earth can ping
herself just fine (both 192.168.5.3 and localhost work).
Still can't ping venus and vice-versa. One more piece of
info - slip is running from earth (slo0) and works fine.

One box (earth) is linux 2.0.18 (Redhat 4.0).
The other box (venus) is WinNT 4.0.

Both cards are recognized by their respective OS's.
The thin coax connects them with terminators on both sides.

ifconfig on earth:
eth0 Link encap:10Mbps Ethernet HWaddr 00:40:05:20:1B:4B
inet addr:192.168.5.3 Bcast:192.168.5.255 Mask:255.255.255.0
UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0
TX packets:138 errors:0 dropped:0 overruns:0
Interrupt:10 Base address:0x340

ipconfig /all on venus:
Windows NT IP Configuration

Host Name . . . . . . . . . : venus.birchstone.com
DNS Servers . . . . . . . . : 129.35.49.2
129.35.17.2
129.38.24.230
Node Type . . . . . . . . . : Hybrid
NetBIOS Scope ID. . . . . . :
IP Routing Enabled. . . . . : Yes
WINS Proxy Enabled. . . . . : No
NetBIOS Resolution Uses DNS : Yes

Ethernet adapter NE20001:

Description . . . . . . . . : Novell 2000 Adapter.
Physical Address. . . . . . : 00-40-33-92-3F-E3
DHCP Enabled. . . . . . . . : No
IP Address. . . . . . . . . : 192.168.5.2
Subnet Mask . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . : 192.168.5.3 (Also tried 192.168.5.2 here)
Primary WINS Server . . . . : 192.168.5.2
Secondary WINS Server . . . : 192.168.5.3

route -n on earth:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.1 0.0.0.0 255.255.255.255 UH 0 0 15 lo
9.3.240.1 0.0.0.0 255.255.255.255 UH 0 0 0 sl0
192.168.5.0 0.0.0.0 255.255.255.0 UG 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 2 lo
0.0.0.0 9.3.240.1 0.0.0.0 UG 1 0 3 sl0

I've tried adding various routes to no avail (maybe I've missed the right one!)

route print on venus:
Active Routes:
Network Address Netmask Gateway Address Interface Metric
0.0.0.0 0.0.0.0 192.168.5.3 192.168.5.2 1
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.5.0 255.255.255.0 192.168.5.2 192.168.5.2 1
192.168.5.2 255.255.255.255 127.0.0.1 127.0.0.1 1
192.168.5.255 255.255.255.255 192.168.5.2 192.168.5.2 1
224.0.0.0 224.0.0.0 192.168.5.2 192.168.5.2 1
255.255.255.255 255.255.255.255 192.168.5.2 192.168.5.2 1

(I also tried 192.168.5.2 as the default gateway as well.)

venus pings it's own IP address just fine.
earth pings it's own IP address just fine now.

Neither machine can ping the other (100% packet loss).
earth does report outgoing TX packets (as seen above in the ifconfig output).

I've entered the ethernet addresses to both machines manually using arp.

Any more advice??

Help please, what could be wrong?
More importantly, what tools/procedures can I follow to identify the
problem. Of course, if you know the solution already you'll make
my week.
Andy Bjorksten
Phone: (512) 838-7704 Tie-line: 678-7704
email: jimb@austin.ibm.com VM PROFS: JIMB AT AUSVM6