Re: checking running kernel version for IP_PKTINFO support

Alan Cox (alan@lxorguk.ukuu.org.uk)
Tue, 9 Mar 1999 23:06:47 +0000 (GMT)


> I'm running a mix of 2.2.x and 2.0.x kernels. My program needs
> to run on both of them only one really supports the IP_PKTINFO
> socket option. Right now I'm just using <linux/version.h>

One way is to issue the ioctl and see if it fails. Another is to use
the data uname does (man 2 uname)

Alan

-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu