Telnet fixed

Mark A. Swope (mswope@ieee.org)
Wed, 10 Mar 1999 11:06:36 -0600


Thanks to all that supplied suggestions and questions that
led to further investigation.

I think that what I did was find that I'd created screwy
hosts.allow and hosts.deny files *before* I tried to
telnet. In addition, the following error message led me
down an incorrect path:
Mar 6 11:45:14 wheezer in.telnetd[174]: warning: /etc/hosts.allow, line 12:
can't verify hostname: gethostbyname(avatar.home.net) failed

I still get the error (and still am not certain why), but
telnet works *iff* I use a fully qualified domain name for
the host (e.g. wheezer.home.net vs. wheezer). I found
out that this error message was a red-herring by running
linux on my laptop (avatar) and trying to telnet into it (w/o
host.allow or host.deny ever being set up on it) and it
worked immediately.

I've got a working system thanks to all of you and now
I'll take the suggestions that many of you made to
1) RTFMs and 2) do something more secure like ssh.

Next thing will be to disallow root login via telnet.

Thank you all.
mas

----------------------------------------------------------------------------
-------------
MilliHelen - n. The amount of Beauty required to launch 1 ship.
-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu