AX25/TCP/IP Help

gary0319 (gary0319@worldnet.att.net)
Sat, 13 Mar 1999 21:49:43 -0600


Hello Linux Lovers
This is my first posting to this group. I am having trouble getting AX25
and TCP/IP to talk to my Kantronics KAM TNC running in the KISS mode. I
would appreciate any suggestions you can give me.
My current system:
Slackware 3.5, kernel 2.0.34 compiled per textbook "Linux Configuration
& Installation 4th Edition".
Applied the patch - 2.0.35 to upgrade the kernel to use with ax25-utils
2.1.42a and net-tools 1.32-alpha.
AX25 and serial support was selected before the kernel was compiled
using menuconfig.

Symptoms:
1. Minicom communications program will work through ttyS0 (com 1) when
connected to an external modem. Connected to BBS without any problem.

2. Next I connect my KAM tnc in KISS mode to ttyS0. The mkiss command
appears in /usr/sbin. Tried the command "mkiss -p -c -h -l -s 1200
/dev/ttyS0 ptyq0"
No error messages were echoed. Is there anyway to tell if the
mkiss is loaded and running?

3. Next command issued " kissattach - i 44.94.248.213 -m 512
/dev/ttyq0 ax0"
(ax0 is name used in the axports file - the only port used for VHF)
Message echo "kissattach: open: I/O error"

4. The ifconfig command shows only the "lo - Loopback" is attached.
Should this also show the radio port if kissattach is working?

5. I assume the axattach command is not used for this configuration as
directed in the HOWTOs for the version I am running? I do not see the
command in any directory.

I understand the problem could be the ax25 support in the kernel but I
have tried recompiling a couple of times with careful consideration for
ax25 and serial support.

Sorry if these questions are too newbie but I do need some elmering.
This is my first round with Linux and ax25. Thanks a lot.

Gary C. Meyer, W0DYD, Minnetonka, MN
gary0319@worldnet.att.net

-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu