RE: AX25/TCP/IP Help

Jim Wilcox (jwilcox@star-nets.com)
Sun, 14 Mar 1999 09:16:47 -0500


I am using Slackware w/ kernel 2.0.35 and ax25-utils-2.1.42a. Here is how I
start my ax25 stuff.

/usr/sbin/mkiss -s 1200 /dev/ttyS0 /dev/ptyq0 /dev/ptyq1
/usr/sbin/kissattach -i 44.36.41.150 /dev/ttyq0 ax0
/usr/sbin/kissparms -p ax0 -t 300 -s 100 -r 25
/usr/sbin/nrattach -i 44.36.41.150 netrom
/usr/sbin/netromd -i
/usr/sbin/mheardd -f
/usr/sbin/ax25d -l
/usr/sbin/ax25rtd

Here is what my axports looks like:

# /etc/ax25/axports
#
# The format of this file is:
#
# name callsign speed paclen window description
#
ax0 KE4IHI-7 1200 255 2 145.070 MHz (1200 bps)

Here is what my nrports looks like:

# /etc/ax25/nrports
#
# The format of this file is:
#
# name callsign alias paclen description
#
#netrom OH2BNS-10 #LNODE 235 Switch Port
netrom KE4IHI-6 IHIDX 235 Switch Port

This works for me. Other that this, you need to make sure your baud rate
from your computer to your TNC is 1200.

Hope this helps!

73's
Jim
KE4IHI

> -----Original Message-----
> From: owner-linux-hams@vger.rutgers.edu
> [mailto:owner-linux-hams@vger.rutgers.edu]On Behalf Of gary0319
> Sent: Saturday, March 13, 1999 10:50 PM
> To: linux-hams@vger.rutgers.edu; linux-net@vger.rutgers.edu
> Subject: AX25/TCP/IP Help
>
>
> Hello Linux Lovers
> This is my first posting to this group. I am having trouble
> getting AX25
> and TCP/IP to talk to my Kantronics KAM TNC running in the
> KISS mode. I
> would appreciate any suggestions you can give me.
> My current system:
> Slackware 3.5, kernel 2.0.34 compiled per textbook "Linux
> Configuration
> & Installation 4th Edition".
> Applied the patch - 2.0.35 to upgrade the kernel to use with
> ax25-utils
> 2.1.42a and net-tools 1.32-alpha.
> AX25 and serial support was selected before the kernel was compiled
> using menuconfig.
>
> Symptoms:
> 1. Minicom communications program will work through ttyS0
> (com 1) when
> connected to an external modem. Connected to BBS without any problem.
>
> 2. Next I connect my KAM tnc in KISS mode to ttyS0. The mkiss command
> appears in /usr/sbin. Tried the command "mkiss -p -c -h -l -s 1200
> /dev/ttyS0 ptyq0"
> No error messages were echoed. Is there anyway to tell if the
> mkiss is loaded and running?
>
> 3. Next command issued " kissattach - i 44.94.248.213 -m 512
> /dev/ttyq0 ax0"
> (ax0 is name used in the axports file - the only port
> used for VHF)
> Message echo "kissattach: open: I/O error"
>
> 4. The ifconfig command shows only the "lo - Loopback" is attached.
> Should this also show the radio port if kissattach is working?
>
> 5. I assume the axattach command is not used for this
> configuration as
> directed in the HOWTOs for the version I am running? I do not see the
> command in any directory.
>
> I understand the problem could be the ax25 support in the kernel but I
> have tried recompiling a couple of times with careful
> consideration for
> ax25 and serial support.
>
> Sorry if these questions are too newbie but I do need some elmering.
> This is my first round with Linux and ax25. Thanks a lot.
>
> Gary C. Meyer, W0DYD, Minnetonka, MN
> gary0319@worldnet.att.net
>

-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu