Problem compiling net-tools 1.50

Jor-el (jorel@ibm.net)
Sat, 17 Apr 1999 10:04:00 -0500 (CDT)


Hi,

To quote from the bottom of the README file :

Some configuration options require recent 2.1.x or 2.2.x kernels
and/or particular versions of the C library. The defaults should be
safe for all common environments but some of the more esoteric
hardware and protocol families may be more touchy. Feel free to send
patches if you have problems.

The Makefile in the lib directory tries to create the utils.o file
by compiling the utils.c program. This program includes the standard
include <linux/pkt_sched.h>, and this file doesnt exist for 2.0.36. On the
other hand, it does exist for the 2.2.5 kernel. Since utils.c is compiled
no matter what the configuration options are, the make will fail for the
2.0 kernels. Is this what was intended, or can the compilation of
'utils.c' be safely removed for the 2.0 kernels?

Jor-el

-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu