3c590 -- convertor -- 3c575?

Alexy Khrabrov (khrabrov@unagi.cis.upenn.edu)
Sat, 17 Apr 1999 20:39:51 -0400 (EDT)


Greetings linux net gurus --

I can't connect my laptop and desktop via a funny
coax ethernet, using a medfiaq convertor and a
PCMCIA card, and I hope somebody solved parts of
similar problems before and can help.

I want to connect my two home PCs, a Dell
Dimension XPS desktop with 3c590-COMBO "Vortex", and
a Dell Inspiron 7000 with 3c575 "Cyclone" Fast
Ethernet XL card. I have a problem which is
either hardware or software, and I see many
symptoms which are interesting. I'd appreciate
any hints on what so examine/try next, and
apologize if this question was covered previously
on the list -- any pointers to any solutions are
welcome.

Since my Vortex is a combo, having coax BNC, and I
also happened to have a media convertor BNC-RJ45
with (a) 10BaseT link pulse sensor (switchable)
(b) RX & Collision indicators at the both ends, I
decided that coax ethernet is what I want -- since
I'll also put my future computers on it, and I
have ethernet capable Macs already.

I run RedHat 5.2 on the Dimension, and same thing
on the Inspiron. Both installations were made out
of the box. However, I recompiled the kernels on
both machines, and I also upgraded the Inspiron's
kernel to 2.2.5 in order to take the full
advantage of the latest PCMCIA tools, 3.0.9. So
3c575 works fine except it dies in its sleep --
doesn't come back after resume, but taking it
out/reinserting puts the link back online. I'll
follow up with the PCMCIA guys on that.

The hardware looks as follows: the media convertor
sits on my desk so I can observe all the
indicators. Convertor's link sense on RJ45 end is
on (since the link sense switch is on and 3c575
responds with pulses as a new RJ45 ethernet device
should). 3c575 LED for 10 Mbps is on, and 100Mbps
is properly off (my convertor is 10Mbps, and so is
Vortex).

The software configuration is as follows: the
Dimension is called yaw, and the Inspiron is
called roll. The /etc/hosts file on both machines
looks as follows:
-----/etc/hosts
192.168.0.1 yaw yaw.suffix.com
192.168.0.2 roll roll.suffix.com
-----.

I configure the eth0 interface on yaw as follows:
$ ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up
$ route add -net 192.168.0.0 eth0

Similarly, I configure roll as follows:
$ ifconfig eth0 192.168.0.2 netmask 255.255.255.0 up
$ route add -net 192.168.0.0 eth0

Each machine can now successively ping itself as
localhost or by name (yaw, roll). However, when I
try to ping another machine, ping waits showing
nothing, and ^C reports all packets transmitted
and lost.

ifconfig on both machines reveals that TX is 0,
and the lost packages show only in the "carrier"
field, not documented in my Olaf Kirsh's book
(1995).

However, a strange quirk can be observed with
netstat -i: all the packages lost on eth0 trying
to ping another machine, and showing only in the
"carrier" field on ifconfig eth0, are showing as
successfully RX and TX for lo, the loopback! So
they never reach the eth0 but somehow go to
loopback statistics?

Saying arp -a on both machines shows empty tables,
nothing there.

And most disturbingly but promising, the following
hardware effects can be observed when trying to
ping another machine:

When pinging yaw from roll, both ends of the
convertor blink RX AND Collision synchronosuly
with the packets to be sent. No RX/TX success is
reported though by ifconfig, only "carrier" (and
strangely on lo's successful RX/TX).

When pinging roll from yaw, no blinking on the
coax end is observed otehr than periodic probably
"sensing" blinks. The coax end of the convertor
blinks every so often, dozens of seconds or so,
even when teh RJ45 end is disconnected.

Now, I am at a loss as to where to look next. Any
comments?

Cheers and regards,
Alexy Khrabrov
University of Pennsylvania
Philadelphia, PA
-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu