Re: router not forwarding...

Vesselin Mladenov (root@netbg.com)
Fri, 23 Apr 1999 19:56:18 +0000 (GMT)


1. Try with:
echo 1 > /proc/sys/net/ipv4/ip_forward

2. It is not neccessary to add routes to directly attached networks (unless
some spacial cases)

On Fri, 23 Apr 1999 arni@snafu.Rutgers.EDU wrote:

> Date: Fri, 23 Apr 1999 12:21:56 -0400 (EDT)
> From: arni@snafu.Rutgers.EDU
> To: linux-net <linux-net@vger.rutgers.edu>, linux-kernel@vger.rutgers.edu
> Subject: router not forwarding...
>
> Hi,
> Here is my topology..(all m/cs are RH 5.2 with 2.2.3 )
>
> Box1 <-----> Box2 <-----> Box3
>
> Box 2 is a router..(cat /proc/sys/net/ipv4/ip_forward has value 1)..and
> the kernel is compiled as a router..
>
> The route table for box 2 is :: (slightly snipped..)
>
> Destination Gateway Genmask Iface
> 10.0.1.0 * 255.255.255.0 eth1
> 10.0.1.0 * 255.255.255.0 eth1
> 10.0.2.0 * 255.255.255.0 eth2
> 10.0.3.0 * 255.255.255.0 eth0
> 10.0.3.0 * 255.255.255.0 eth0
> 127.0.0.0 * 255.0.0.0 lo
>
> (why the duplication in route table..??)
>
> Now what happens is packets go from 1 to 2 and also from 2 to 3 but not
> from 1 to 3..why is that..This used to work before..till all of a sudden
> it
> seemed to stop working..
>
> Also from 1 and 3 I can ping all the interfaces of 2..
>
> Any suggestions..??
>
> Thanks,
> Arni
>
>
> -
> To unsubscribe from this list: send the line "unsubscribe linux-net" in
> the body of a message to majordomo@vger.rutgers.edu
>

---------------------------
Vesselin Mladenov
NetBG Communications Ltd.
Phone 1: +3592-9744260
Phone 2: +3592-9744261
---------------------------

-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu