pppd / modem disconnect

Marc Owen (mowen@gmx.net)
Sun, 20 Jun 1999 06:08:30 +0200


Hi,

It's the first time I write to a mailinglist like this. I usually solve my
own problems, but this time I really can't find the prob. All I want to do
is connect to the net through linux, but every time pppd disconnects me when
I am logged in. I tried 2 different ISP's (all using PAP) and about 4
different login servers, but every single one gives the same problem.
Everything goes fine, I call to my ISP, get connected, send my login and
pass (checked it with minicom), my provider's server starts ppp, I see
the }'s coming, but then my modem disconnects. My login and password are ok,
and my ISP's all use PAP. I played around with some pppd-parameters, without
succes. I reinstalled pppd, reconfigured my kernel, all without succes.

I am using slackware 3.6 kernel 2.0.35 (Hm... I updated some things, but
basically still that kernel). My modem is a 33.6 standard thinggy (NO
winmodem :) ). My log says:

May 18 01:43:03 voodoosystem kernel: registered device ppp0
May 18 01:43:04 voodoosystem pppd[214]: pppd 2.2.0 started by voodoo, uid 0
May 18 01:43:06 voodoosystem chat[216]: timeout set to 60 seconds
May 18 01:43:06 voodoosystem chat[216]: abort on (ERROR)
May 18 01:43:06 voodoosystem chat[216]: abort on (BUSY)
May 18 01:43:06 voodoosystem chat[216]: abort on (NO CARRIER)
May 18 01:43:06 voodoosystem chat[216]: abort on (NO DIALTONE)
May 18 01:43:06 voodoosystem chat[216]: send (AT&FH0^M)
May 18 01:43:06 voodoosystem chat[216]: expect (OK)
May 18 01:43:24 voodoosystem chat[216]: AT&FH0^M^M
May 18 01:43:24 voodoosystem chat[216]: OK -- got it
May 18 01:43:24 voodoosystem chat[216]: send (atdt*31*2064911#^M)
May 18 01:43:25 voodoosystem chat[216]: timeout set to 75 seconds
May 18 01:43:25 voodoosystem chat[216]: expect (CONNECT)
May 18 01:43:25 voodoosystem chat[216]: ^M
May 18 01:44:14 voodoosystem pppd[214]: Serial connection established.
May 18 01:44:14 voodoosystem chat[216]: atdt*31*2064911#^M
May 18 01:44:14 voodoosystem chat[216]: CONNECT -- got it
May 18 01:44:15 voodoosystem pppd[214]: Using interface ppp0
May 18 01:44:15 voodoosystem pppd[214]: Connect: ppp0 <--> /dev/cua2
May 18 01:44:54 voodoosystem pppd[214]: Modem hangup
May 18 01:44:54 voodoosystem pppd[214]: Connection terminated.
May 18 01:44:54 voodoosystem pppd[214]: Exit.

During boot, everything seems ok:

May 12 19:26:09 voodoosystem kernel: SLIP: version
0.8.4-NET3.019-NEWTTY-MODULAR (dynamic channels, max=256).
May 12 19:26:09 voodoosystem kernel: PPP: version 2.2.0 (dynamic channel
allocation)
May 12 19:26:09 voodoosystem kernel: PPP Dynamic channel allocation code
copyright 1995 Caldera, Inc.
May 12 19:26:09 voodoosystem kernel: PPP line discipline registered.

If somebody has the *slightest* idea what could be wrong, please send me a
mail. I am trying to fix it for already a few months now, and nobody seems
to be able to help me (my ISP's both just say 'linux not supported' :( ).

_____
Marc Owen

-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu