Re: Bug in CBQ? (AND: Call for help with testing)

Christian Worm Mortensen (worm@dkik.dk)
Tue, 22 Jun 1999 17:13:18 +0200


Hi again,

>To be honest, the situation looks impossible. The configuration
>is too simple to show so terrible bug. 8) Well, one more question:
>what ethernet driver do you use?

I have now tried it on another machine with the same result...., so all in
all:

Machine A) Has an RTL8029 based card and an RTL8139 based card. The problem
was there when attaching CBQ to the RTL8029 card (have not tried with the
RTL8139 card).

Machine B) only has an RTL8139 card and the problem was there when attaching
to that.

The only identical hardware in the two machines is the RTL8139 card. They
are both based on the same Redhat-network-installation-image and the same
kernel source. The source was, however, compiled seperatly on the two
machines.

Anyone else who will try? To summerize, the two commands:

====
tc qdisc add dev eth0 root handle 1: cbq bandwidth 10Mbit allot 1514 cell 8
avpkt 1000 mpu 64

tc class add dev eth0 parent 1:0 classid 1:1 cbq bandwidth 10Mbit rate
64Kbit weight 6Kbit allot 1514 cell 8 avpkt 1000 mpu 64 prio 5 bounded
defmap ffff split 1:0
===

seems to make eth0 go down in less than an hour at least when it has some
trafic.

Christian

-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu