Problems with a Macronix MX98715 / MX98725 (rev 32) ethernetcard

Fredrik Nilsson (niescha@ludd.luth.se)
Sat, 4 Sep 1999 02:58:42 +0200 (CEST)


Hi!
I have just bought a ethernetcard (10/100Mbit PNP), NE2000 PCI
compatible according to the store. But when I tried to compile the generic
NE2000 PCI(ne2k-pci.o) support in to the kernel it just wouldn't work,
so I tried with all the other devices instead and found that DECchip
Tulip(tulip.o) worked just fine, btw here is what the syslog says after I
inserted the tulip.o module into the kernel.

Sep 4 03:24:22 galilei kernel: tulip.c:v0.89H 5/23/98 becker@cesdis.gsfc.nasa.gov
Sep 4 03:24:22 galilei kernel: eth1: Macronix 98715 PMAC at 0xe800, 00 80 ad 7a df 2$
Sep 4 03:24:22 galilei kernel: eth1: EEPROM default media type 10baseT.

After I had done that i tried to config the device with ifconfig like
this:

[root@galilei lek]# ifconfig eth0 10.0.0.1 netmask 255.0.0.0 up

with the following result

Unable to handle kernel NULL pointer dereference at virtual address
00000010
current->tss.cr3 = 04ef4000, %cr3 = 04ef4000
*pde = 00000000
Oops: 0000
CPU: 0
EIP: 0010:[<c5a1f9f9>]
EFLAGS: 00010246
eax: c1cfe140 ebx: 00000010 ecx: 00000000 edx: c0fd05e0
esi: c0fd05e0 edi: c0fd05e0 ebp: 00000000 esp: c4035e00
ds: 0018 es: 0018 ss: 0018
Process ifconfig (pid: 4270, process nr: 39, stackpage=c4035000)
Stack: c0f47800 00000000 00000624 00000008 000001f0 0000001f c0f47800
c5a2127b
00000612 00000008 00000000 c1cfe140 c0f47800 00001043 00000000
c0fd05e0
c0f47800 0000e800 c0f47a1c c0f47810 c5a1f848 c1cfe140 00000001
00001002
Call Trace: [<c5a2127b>] [<c5a1f848>] [<c0193d69>] [<c0193fed>]
[<c0175749>] [<c01761$
[<c01766ed>] [<c0192ff7>] [<c0171ccd>] [<c012d675>] [<c0109cf8>]
Code: 8a 13 88 50 3c 83 7c 24 60 00 74 18 8b 54 24 44 31 c9 8a 4a
Segmentation fault
[root@galilei lek]#


Have I missed a step in the config procedure or is this a bug in the kernel that
should be discussed on the linux-kernel list?
I'm running kernel 2.2.12

Some additional data fetched from /proc/pci

Bus 0, device 8, function 0:
Ethernet controller: Macronix MX98715 / MX98725 (rev 32).
Medium devsel. Fast back-to-back capable. IRQ 11. Master Capable. Latency=6$
I/O at 0xe800 [0xe801].
Non-prefetchable 32 bit memory at 0xe9000000 [0xe9000000].

I'm thankfull for all help I can get to solve this problem.
/Fredrik

-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu