installing a 2nd network interface card problems

root (daflos.andreas@gmx.at)
Sun, 05 Sep 1999 17:20:49 +0200


i am a poor novice in the linux-world, and i want to install a 2nd NIC
under
linux in order to use samba.
i have the suse linux 6.2 with kernel 2.2.10. the eth0 is a 3com 905B
and is being fully recognized and configured from the kernel. however
the eth1 which is a D-Link 528 CT, is not recognized at all. using yast
is tried to 'integrate hardware into system' and went to 'configure
network interface card'. there i see the eth0 devive listed correctly. i
changed the eth0 to eth1 and chose another card-type from the menu below
(i used a 'realtek 8129' for i suppose this can be used as kind of
'generic driver' for my D-Link NIC). however, this didnt work, as i
restart the network i recieve the error 'eth1 unknown device' and 'eth1:
no such device' as well as 'shutdown eth1 failed'
i tried (after resetting every change i did) then using the boot
parameter 'ether=0,0,eth1' with lilo, but again, i didnt succeed. so i
looked for real drivers for my D-Link card from dlink.com. i found some
drivers there, but i am not sure i can use them, for it seems that i
have to recompile the kernel (!!??).

i will appreciate any suggestions

thanks in advance

A.D.
-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu