problems between router and local node

Ximo Domenech (ximo.domenech@ival.es)
Fri, 10 Dec 1999 09:02:21 -0100


Hi to everyone,
I have a big problem with my ppp that I can't solve. I have implemented
a local node with linux + Cyclades multiport card (Cyclom Y 8 ports) +
mgetty + some modems. Now there are five modems running perfectly, 4 of
them analogic USR and 1 of them Dynalink (RDSI modem). Clients connect
to the local node from windows machines and go from the local node with
a static IP address to the internet, and all is running ok. A few days
ago I tried to connect one RDSI router (Allied Telesyn AR300L) to the
local node, and the surprise was that it wasn't work !!
Why ??
Router connected to the local node ok, but if you open a navigator
window you can't connect anywhere. From the client you can ping to the
local node, but from the local node you can't ping to the client. PPP
logs says that connection is OK.
Here is some of my configuration:

in /etc/inittab

s4:45:respawn:/usr/local/sbin/mgetty -D -x9 -s 115200 -m '"" ATE1Q0S0=1
OK' /dev/ttyC4
^
|
|
--- that's for the RDSI modem

/etc/ppp/options.ttC4

auth
-chap
+pap
login
debug
local_node_IP:remote_assigned_IP
proxyarp

I have found the next error messages in /etc/ppp/log, but I think thats
not the problem:
Hangup (SIGHUP)

Dec 9 19:37:55 pppd[898]: Modem hangup
Dec 9 19:37:55 pppd[898]: ioctl(SIOCDARP): No such file or directory(2)
Dec 9 19:37:55 pppd[898]: Connection terminated.
Dec 9 19:37:55 pppd[898]: ioctl(SIOCDARP): No such file or directory(2)

I would be very happy if someone can help me, I have tried a lot of
configurations and I have had very bad luck.
Thanks,

__________________________________________________

Ximo Domenech ximo.domenech@ival.es
Internet Valencia 96 352 35 30
http://www.ival.es
-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu