PLEASE HELP! -- Trying to set-up NAT on RH6?

Neil Aggarwal (neil@JAMMConsulting.com)
Sat, 11 Dec 1999 12:21:50 -0600


Hello:

I have been unsuccessful with setting up NAT on RH 6.
I have posted the same question several times
to this newgroup to no avail.

Has anyone successfuly set-up NAT on RH6?
The docs suck and the tools are horrible.
I need some help here!

Thanks,
Neil.

PS: Here is my current status:
-----------------------------------------------------------
I am trying to set up an IP NAT alias for a machine using
an internal IP address of 192.168.2.2.

The external address for this machine should be 216.87.xxx.yyy

Here are the ip commands I issued:
ip route add nat 216.87.xxx.yyy via 192.168.2.2
ip rule add from 192.168.2.2 nat 216.87.xxx.yyy

If I do:
ping 192.168.2.2
Everything works fine.

But, when I do
ping 216.87.xxx.yyy
I get timeouts.

When I type:
ip rule show
I see an entry for the external address.

When I type:
ip route show
I dont see an entry for the external address.
Does this mean something is wrong with the ip route
command?

Any ideas?
-----------------------------------------------------------

**We pay a 5% finders fee for job referrals that lead to a contract*
--------------------------------------------------------------------
|Neil Aggarwal |JAMM Consulting, Inc. |Custom Programming |
|President & CEO |www.JAMMConsulting.com|Java, C, C++, perl,|
|neil@JAMMConsulting.com|(972) 612-6056 |HTML, CGI |
--------------------------------------------------------------------
-
To unsubscribe from this list: send the line "unsubscribe linux-net" in
the body of a message to majordomo@vger.rutgers.edu